diff options
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -1,4 +1,4 @@ -.PHONY: all clean run sanitize backends +.PHONY: all clean run sanitize backends full backends-full OBJS = config.o backend.o plugin.o PLUGINDIR = "\"./backends/\"" @@ -19,9 +19,14 @@ endif all: midimonster backends +full: midimonster backends-full + backends: $(MAKE) -C backends +backends-full: + $(MAKE) -C backends full + # This rule can not be the default rule because OSX the target prereqs are not exactly the build prereqs midimonster: midimonster.c portability.h $(OBJS) $(CC) $(CFLAGS) $(LDFLAGS) $< $(OBJS) $(LDLIBS) -o $@ |